پياده سازي تونل GRE

براي ارتباط دو شعبه مختلف يك شركت، از طريق شبكه اينترنت، روشهاي مختلفي وجود دارد كه يكي از اين روشها استفاده از تونل GRE مي باشد.

شكل زير را در نظر بگيريد :

GRE

فرض بر اين است كه روتر Core روتر يك شركت SP بوده كه در شبكه اينترنت واقع بوده و IP هاي 192.168.1.0/24 و 192.168.2.0/24 را در Routing Table خود ندارد.هدف برقراري ارتباط LAN روترهاي R1 و R2 از طريق شبكه اينترنت مي باشد.

از آنجاييكه IP هاي اين LAN ها Invalid مي باشد لذا از طريق شبكه اينترنت Route نخواهند شد.

كانفيك ايجاد تونل GRE بر روي روترهاي R1 و R2 به شرح زير خواهد بود :

R1(config)# interface Tunnel 0

R1(config-if)# ip address 172.16.1.1   255.255.255.252

R1(config-if)# tunnel mode GRE IP

R1(config-if)# Tunnel source    10.10.10.1   

R1(config-if)# Tunnel destination 10.10.11.2      

R1(config)# ip route 192.168.2.0      255.255.255.0 tunnel 0



R2(config)# interface Tunnel 0

R2(config-if)# ip address 172.16.1.2   255.255.255.252

R2(config-if)# tunnel mode GRE IP

R1(config-if)# Tunnel source      10.10.11.2   

R1(config-if)# Tunnel destination      10.10.10.1      

R1(config)# ip route 192.168.1.0      255.255.255.0 tunnel 0



براي اطمينان از درستي كانفيگ انجام شده ، از روي روتر R1 ، روتر R2 را با سورس LAN روتر R1 پينگ ميكنيم:

R1# ping 192.168.2.1 source 192.168.1.1



براي چك كردن وضعيت تونل هم ميتوان از كامند زير استفاده كرد :

Show interface tunnel 0